Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Tastplatte funktioniert nicht.
#1
Hallo zusammen, ich werde noch wahnsinnig. Habe an meiner 3018 pro je Achse 2 Endschalter parallel und einen Werkzeuglängensensor angeschlossen. Funktioniert soweit alles gut. Nun hab ich mir eine Tastplatte gekauft und krieg die mit Estlcam nicht zum Laufen. Die Tastplatte sitzt am Anschluss 6 der Längensensor auf 7 und dann eben noch die endschalter pro Anschluss je zwei Schalter. 

Habe die Spindl mit einer Kroko geerdet. Hab schon den Stecker umgedreht alles ohne Erfolg. Was mache ich falsch? Was kann ich noch probieren? Estlcam hat das letzte Update drauf.

Danke

Grüße
Bernhard
Zitieren
#2
Hast du denn mal kontrolliert, ob eine Verbindung zwischen Fräser und Tastplatte besteht?
Gruß Uwe
Stepcraft 600/2, Sorotec Compact-Line 605, EstlCAM, WinPcNc V3, DIY Reprap Prusa i3, Ender 3, 15W Laser (noch in der Erprobung), 4. Achse (Drehachse)

Anfragen, die einem Themenbereich im Forum zugeordnet werden können, bitte auch dort stellen. Entsprechende Fragen per Mail oder PN werden nicht beantwortet.


YouTube
Zitieren
#3
Guten Morgen Uwe,

sorry, wie mach ich das? Ich werd jetzt noch einen anderen Anschluss ausprobieren, dann mal den Werkzeuglängensensor entfernen und dann nochmal probieren. Die Kabel von der Tastplatte zum Anschluss hab ich durchgemessen. Vielleicht sollte ich die Kroko zum Fräser mal weglassen.

Gruß
Bernhard
Zitieren
#4
Nochmal ich,

hab jetzt alles versucht, was mir eingefallen ist. Kann es sein, dass sowohl WLS als TP nur an einem Anschluss funktionieren? Momentan hab ich WLS an A5 und die TP an dem Anschluss der mit X-Achse bezeichnet ist. Sind ja jeweils 2 Anschlüsse pro Achse vorhanden. Auf dem zweiten x-Anschluss hab ich die  beiden Endschalter für die X-Asche, auf dem ersten Anschluss für die Y-Achse habe ich die 2 Endschalter für die Y-Achse, der zweite Anschluss für die Y-Achse ist frei, bei der Z-Achse ist es analog zur Y-Achse. Muss ich evtl. den WLS und den TP parallel an A5 anschliessen?

Danke
Gruß
Bernhard
Zitieren
#5
Moin,

(28.07.2020, 21:33)flashover333 schrieb: ... 2 Endschalter parallel und einen Werkzeuglängensensor angeschlossen.

Parallel...

...das glaub ich nicht. Bei allen Käsefräsen, die ich kenne, sind das Öffner und keine Schließer.
Das deine Öffner sind, zeigt die Tatsache, das deine Tastplatte nich funzt.

Der WZL ist auch ein Öffner und der funzt ja, nach deiner Aussage.

Die Tastplatte ist aber ein Schließer und die kann nicht parallel geschalten werden. Du brauchst einen seperaten Eingang an deiner Hardware und musst deinem Steuerprogramm auch mitteilen, das der WZL jetzt ein Schießer ist und auf einem anderen Eingang liegt.
sswjs, aka Jens

High-Z 1000, FME1050, FME1050-1, Stepcraft 600 V1, FME1050-1, Solidworks, HSMXpress, ESTLCam, NC-Corrector, WINPC-NC 2.5
Zitieren
#6
Hallo Uwe, hallo Jens,

ich hab die Tastplatte ja bisher an einem separaten Eingang angeschlossen. Wenn ich dich richtig verstehe, dann muss ich den Eingang der Tastplatte invertieren oder? Das hab ich bisher noch nicht versucht, werde es heute Abend gleich mal testen.

Jetzt ist mir noch was aufgefallen. Ich habe als Steuerungselektronik GRBL 0.9 - 1.1 mit PWM eingestellt, kann es daran liegen?
Es werden auch nur 7 Eingänge in Estlcam angezeigt. Habe mal GRBL alle ausgewählt, dann stehen 8 Eingänge zur Verfügung.
Kann es daran liegen?

Danke

Bernhard
Zitieren
#7
@ flashover333
Bitte nicht mehrere Themen für 1 Problem erstellen, darum wurde dieser Beitrag hierher verschoben.



Hallo zusammen,
bevor ich mein Problem beschreibe, möchte ich erstmal die Frage stellen, ob es überhaupt schon wer geschafft hat an der CNC 3018 Pro mit der Steuereinheit Woodpecker CNC CamXTool V3.4 GRBL 1.1 eine Tastplatte zum Laufen zu bringen??????

Habe nämlich folgendes Problem, dass ich nicht lösen kann. Zur Steuerung meiner CNC 3018 Pro (Steuereinheit Woodpecker CNC CamXTool V3.4 GRBL 1.1) nutze ich Estlcam.  

Die Einstellungen für Estlcam habe ich aus dem sehr guten YouTube-Video (https://www.youtube.com/watch?v=EsrabYq3ZVU) ab Minute 7 übernommen.
Habe an der Steuereinheit einen WLS an A5 angeschlossen, rechts daneben habe ich eine Tastplatte (an der Steckplatzbezeichnung X-Achse-Endschalter) angeschlossen. Am zweiten X-Achsenanschluss sind zwei Endschalter (parallel) für die X-Achse, am ersten Y-Anschluss zwei Endschalter (parallel) für die Y-Achse, der zweite Steckplatz ist nicht belegt, dass gleiche analog bei den mit Z-Achse bezeichneten zwei Anschlüssen.
Der WLS und alle Endschalter funktionieren einwandfrei nur die Tastplatte funktioniert nicht. Hab alle Werte der Tastplatte (Breite- Länge- Dicke usw.) eingetragen. Die Tastplatte habe ich genauso wie den WLS (GND mit Krokodilklemme) angeschlossen.
 
Ach ja die Steuerung, da habe ich in Estlcam von den drei Möglichkeiten die Möglichkeit GRBL 0,9-1.1 mit PWM (wie in YouTube-Video beschrieben) verwendet. Mir ist aufgefallen, dass Estlcam dann 7 Anschlüsse anbietet. Den WLS und die TP habe ich als Sensor definiert.

Hab heute mal probehalber die Einstellung „GRBL alle“ umgestellt, dann zeigt Estlcam 8 Anschlussmöglichkeiten, wobei der dritte Anschluss immer als ausgelöst angezeigt wird und die Endschalter dann auf den Anschlüssen 1,2 und 4 zu finden sind. Keine Ahnung warum der dritte ausgelöst ist, hab ihr invertiert, damit die Anzeige weggeht. Hab das aber noch nicht mit der Fräse ausprobiert. Kann da das Problem liegen? Noch eine Frage ist die Tastplatte ein Öffner oder ein Schließer? muss ich den Anschluss ggf. invertieren? Hab die beiden Kabel der Tastplatte durchgemessen, also die Leitungen gehen durch.
Der ganze linke Anschluss neben dem mit A5 bezeichneten Anschluss, da steht 5V drauf, für was ist der? Sollte ich die Tastplatte da mal anschließen??

Hab mal die Tastplatte an den Anschluss des WLS angeschlossen, auch ohne Erfolg.

Danke.
Grüße 
Bernhard
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste