Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Estlcam /WinPC-NC Problem mit Drehzahlkommentar
#1
Hallo,
ich habe ein Problem, dass ich die Drehzahl der Estcam Datei (20000 U/min)
nicht über das Vorschub/Drehzahl-Panel in WinPC-NC auf 25000 U/min ändern kann.

Herr Lewetz berichtet, dass in der Estcam Datei der Drehzahl-Kommentar ohne Klammern steht
und das zu Problemen führen könnte.
Außerdem ist auch der M6 Befehl nach Kommentar nicht korrekt.
Er kann auch mit meinem Profil die Drehzahl größer 100% verändern.



Ich habe hier mal den Programm Anfang aus Estlcam eingefügt:

%
(Projekt <project>)
(Erstellt mit Estlcam Version <version> Build <build>)
(Laufzeit ca. <time> Stunden)

(Benötigte Werkzeuge: )
<tools>

G90
T<t> M06 S<s>
M03



Was muss ich denn jetzt genau ändern?

Damit es korrekt ist, so wie Herr Lewetz meint.

Ich würde mich über hilfreiche Antworten freuen.

Schönen Abend noch.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#2
Deine Einstellungen in Estlcam sollten korrekt sein und der Programmanfang sollte dann so aussehen:

%
(Projekt tp)
(Erstellt mit Estlcam Version 11 Build 11,231)
(Laufzeit ca. 00:05:15 Stunden)

(Benoetigte WerkzeugeSmile
(Fraeser 5mm)

G90
T2 M06 S20000
M03

Es könnte aber auch mit der Ansteuerung für deine Spindel zusammenhängen. Wird die bei dir auch über 0 - 10V angesteuert und wenn ja, hast du die anliegende Spannung mal gemessen?
Gruß Uwe
Stepcraft 600/2, Sorotec Compact-Line 605, EstlCAM, WinPcNc V3, DIY Reprap Prusa i3, Ender 3, 15W Laser (noch in der Erprobung), 4. Achse (Drehachse)

Anfragen, die einem Themenbereich im Forum zugeordnet werden können, bitte auch dort stellen. Entsprechende Fragen per Mail oder PN werden nicht beantwortet.


YouTube
Zitieren
#3
Moin,

in WinPC-NC funktioniert die Spindel über Sonderfunktionen > Signaltest einwandfrei.
Ja ich habe die Werte auch vorher gemessen gehabt, 100% sind 10V.

Der Lewetz hat mir ja auch geschrieben dass er mit meinem Profil,
bei sich die Drehzahl auch über 100% regeln kann.

Mein Programmstart sieht mit der aktuellsten Estlcam Version v11.231 nun so aus:

%
(Projekt Test Alu Kreis 25)
(Erstellt mit Estlcam Version 11 Build 11,231)
(Laufzeit ca. 00:06:58 Stunden)

(Benoetigte WerkzeugeSmile
(3,175mm Z2 Alutest)
(Fase Z3 90 Grad Soro)

G90
T1 M06 S20000
M03
G00 Z7.0000


Ein heutiger Test hat aber wieder gezeigt dass das Regeln der Drehzahl nach oben hin nicht funktioniert. Sad 
Auch bei einer Gegenkontrolle mit einem gCode aus Vectric funktioniert das Erhöhen der Drehzahl
über 100% nicht.


Ich habe hier mal in gepackter Form die Estlcam Datei und mein WinPC Profil angehängt,
vielleicht hilft das weiter den Fehler zu finden.


.zip   v231.zip (Größe: 19,06 KB / Downloads: 5)


Funktioniert das Anheben der Drehzahl über 100% mit dieser Datei bei Euch in WinPC-NC?
Dann kann es die Estlcam Datei (gCode) dann ja eigentlich nicht sein.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#4
Hallo,

aus meiner Sicht sind die Drehzahlbefehle und Kommentare im geposteten Beispiel alle OK und den üblichen Gepflogenheiten entsprechend.
Wurde gesagt was konkret falsch ist bzw. wie es stattdessen korrekt wäre?

Christian
Zitieren
#5
Hallo,

ich habe eben gesehen, dass mit der neuen Version ein anderer Programmstart generiert wurde,
denn in einer älteren Datei sah der Startcode so aus:

%
(Projekt Kreis 25 12pr seitl)
(Erstellt mit Estlcam Version 11 Build 11,222)
(Laufzeit ca. 00:07:13 Stunden)

(Benoetigte WerkzeugeSmile
(3,175mm Z2 Alutest)
(Fase Z3 90 Grad Soro)

G90
T1 (3,175mm Z2 Alutest) M06
Drehzahl 20000
M03

G00 Z7.0000


Herr Lewetz meinte wohl dass es mit dem Wort Drehzahl zusammenhängt, keine Ahnung.
Mit der neuen Software stimmt der Code jetzt jedenfalls, auch aus Sicht von Herrn Lewetz.

Achso,

ich habe auch mit Vectric dann mal einen gCode der selben Datei generiert
und da funktioniert die Drehzahlanhebung über 100% auch nicht,
also kann es auch nicht an der Estlcam-Datei liegen.

Hier mal die Mail von Hr. Lewetz:


Zitat:Hallo,
danke für Ihre Mail.
 
Ich kann auch mit Ihren neuen Daten das problem leider nicht nachvollziehen.
 
Ich habe Ihr Profil geladen und die EInstellungen kontrolliert. Am PWM-Ausgang hängt ein Oszilloskop, damit ich den Wert genau beobachten kann.
 
Wenn ich den Job starte dann zeigt das Fortschrittsfenster für die Spindel 100% an, was in der NC-Datei den 20000 U/Min entspricht. Der PWM-Wert ist etwa 80%.
 
Ich kann dann problemlos den Spindeloverride erhöhen und in der Anzeige erscheint das immer mit 5% Schritten größer. Auch der PWM-Wert am Oszi wird größer bis er bei 130% dann Vollausschlag hat und PWM 100% entspricht. Das sind dann die 25000 U/min, die bei Ihnen als Maximaldrehzahl eingestellt sind.
Man kann mit weiteren Klicks auf die Buttons in der Anzeige das noch weiter erhöhen also auf 140% oder 150% aber der PWM-Wert wird natürlich nicht mehr größer als 100% Vollausschlag.
 
Ich weiß nicht was ich noch testen soll.
 
Auch in Ihrem Protokoll habe ich von WinPC-NC an die USB-DLL die Kommandos für das Erhöhen über 100% gesehen und das sieht wie erwartet aus.



Ich nutze ja die StepMax3/30 aus dem Hause Lewetz und WinPC-NC USB v3.40/72 auch von Lewetz,
da müsste es doch eigentlich möglich sein dies korrekt zum Laufen zu bekommen.

Wenn der Entwickler und Hersteller der Hard-und Softwaresteuerung nicht weiß,
was er noch testen soll, woher soll ich es dann wissen?

Ich werde am Montag mal anrufen und fragen ob man evtl. mal die Hardware-Steuerung überprüfen sollte,
ob da evtl. erneut ein Fehler vorliegt, denn es wurde von Seiten Hr. Lewetz
mal erwähnt dass bei meiner Steuerung ein Chargenfehler vorliegt.
Das war als ich die Steuerung das letzte Mal zur Überprüfung eingeschickt habe.

Evtl. bietet Hr. Lewetz mir ja an eine Teststeuerung zukommen zu lassen,
dann könnte man gleich sehen ob es an meiner Hardware liegt.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#6
Du solltest mal die Spannung direkt am Eingang deiner Spindelsteuerung messen. Bei max 25000 1/U und 20000 1/U Vorgabe, sollten dort 8V anliegen. Wenn du jetzt die Drehzahl in WinPc anhebst, sollte die Spannung am Eingang schrittweise bis auf 10V steigen.
Gruß Uwe
Stepcraft 600/2, Sorotec Compact-Line 605, EstlCAM, WinPcNc V3, DIY Reprap Prusa i3, Ender 3, 15W Laser (noch in der Erprobung), 4. Achse (Drehachse)

Anfragen, die einem Themenbereich im Forum zugeordnet werden können, bitte auch dort stellen. Entsprechende Fragen per Mail oder PN werden nicht beantwortet.


YouTube
Zitieren
#7
Hallo Uwe,

Danke für den Tipp, das werde ich morgen gleich mal testen.

Schönen Abend noch.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#8
Hallo Uwe,

also ich habe heute die Voltzahlen gemessen.

Bei den 20.000 U/min aus der Estlcam Datei, also 100% Drehzahl in WinPC liegen 7,6V an.
Erhöhen ich den Regler ändert sich nichts an der Drehzahl und auch nichts an den 7,6V.

Daraufhin habe ich unter Einstellungen > Signaltest mal das PWM auf 100% angehoben und gemessen,
da hatte ich 10V anliegen.  So sollte es ja eigentlich auch sein, richtig?

Daraufhin habe ich die Estlcam Datei Drehzahlmäß0ig mal auf 10.000 U/min gesetzt und gemessen.
Bei 10.000 U/min konnte ich 2,6V messen, hier funktionierte dann das Anheben der Drehzahl und der Spannung
aber auch nur bis 155%.
Bei 155% hatte ich eine Spannung von 4,13V anliegen.

Ich hänge mal ein Foto meines 24V Netzteils und der Anschlussbelegung der AMB Spindel an,
vielleicht liegt hier ja der Hund begraben.

   

Die Steuerleitung der Fräse (braun, weiss, grün) habe ich wie folgt an das mittlere Netzteil angeschlossen:

Braun an die rechte +V Klemme am Netzteil
Grün an das analoge 10V Signal der StepMax3/30
Weiss an die linke -V Klemme am Netzteil

   

Oder ist das 24V/2,5A Netzteil einfach zu schwach ?

Ich bin ratlos Huh
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#9
Das hört sich alles sehr seltsam an, zumal der Signaltest ja seine 10V liefert. O.K. das Netzteil ist mit 2,5A recht schwach, doch zur reinen Drehzahlsteuerung sollte das aber ausreichen.

Versuche doch mal folgendes:
Das grüne Kabel von der StepMax3/30 abklemmen und dort die Meßleitung anklemmen.
Nun dieses Programm laden, Nullpunkt XYZ an beliebige stelle legen und Maschine auf den Nullpunkt XYZ fahren. Jetzt das Programm starten.
%
G90
S6250
M03
G04 F5000
S12500
G04 F5000
S18750
G04 F5000
S25000
G04 F5000
G01 X0.0000 Y0.0000 Z0.0000 F500
M05
M30

Die gemessenen Spannungen sollten jeweils für 5sek anliegen und nacheinander 2,5V - 5V - 7,5V - 10V betragen.
Wenn dem so ist, das grüne Kabel wieder anschließen und Messung wiederholen. Es sollten die gleichen Werte angezeigt werden.
Gruß Uwe
Stepcraft 600/2, Sorotec Compact-Line 605, EstlCAM, WinPcNc V3, DIY Reprap Prusa i3, Ender 3, 15W Laser (noch in der Erprobung), 4. Achse (Drehachse)

Anfragen, die einem Themenbereich im Forum zugeordnet werden können, bitte auch dort stellen. Entsprechende Fragen per Mail oder PN werden nicht beantwortet.


YouTube
Zitieren
#10
Hallo,

ich habe eben mal den Versuch gestartet und die Messungen durchgeführt.

Hier die Messergebnisse:

S6250 = 0,85V

S12500 = 3,93V

S18750 = 6,97V


S25000 = 10V


Da ich das grüne Kabel mit einer Wagoklemme verbunden habe, konnte ich direkt messen.




Ich hatte anschließend mal die Zeit auf 15 Sekunden hochgesetzt und mal versucht
herauszufinden in welchem Bereich sich die Spindel während des Programmablaufs regeln lässt.


S6250 = 0,85V  bei 65% der Drehzahlanzeige fängt die Spindel an zu drehen, lässt sich aber nicht regeln

S12500 = 3,93V Spindel lässt sich regeln bis 160%, darüber konstante Drehzahl

S18750 = 6,97V Spindel lässt sich regeln bis 110%, darüber konstante Drehzahl


S25000 = 10V Spindel lässt sich regeln bis 75%, darüber konstante Drehzahl


Vielleicht hilft das etwas weiter.


PS: sollte das grüne Kabel unbedingt von der Stepmax abgeklemmt werden?
Dann müsste ich die Messung halt wieder holen, wenn das entscheident ist.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.231, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste