Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
CNC-Fräse Bausatz mit Arduino UNO Clone und CNC Shield V3 Einstellungen richtige Trei
#1
Hallo zusammen,
 
habe mir den CNC-Bausatz https://www.instructables.com/id/LOW-COS...-CNC-MILL/ bestellt. Weil ich es nicht erwarten konnte bis die Teile aus China da sind, habe ich noch einen zweiten Arduino Uno Clone und ein CNC Shield V3 von KeeYees bei Amazon gekauft. Hab es schon zusammengebaut, die Arduino-Software und Treiber installiert um zu sehen, ob auf dem Board ein Bootloader drauf ist. Ist Gott sei Dank da und es funktioniert auch alles soweit. Nun hänge ich an dem Problem, dass ich nicht weiß welchen Wert ich für die Treiber auf dem Shield einstellen soll. Je mehr ich lese, desto verwirrter werde ich. Habe die Treiber DRV 8825 verbaut. 

Laut Beschreibung, siehe Anhang haben die Motoren 2,1 A und einen Widerstand von 1,6 Ohm (siehe Datenblatt) 
.pdf   NEMA17 Schrittmotor.pdf (Größe: 222,97 KB / Downloads: 1)
Ich hab da von Berechnungen der Treiberspannung von Vref (max) was immer das auch heißen mag = max. Motorstromstärke/2, das würde in meinem Fall heißen 2,1 A /2 = 1,05 V. Wenn man aber max 70-80% davon verwenden soll, würde ich bei 70% bei 0,735 V liegen.
 
Da gibt’s aber auch noch die Berechnung, wo der Widerstand mit eingerechnet wird. Ich hab da schon einen auf dem Treiberboard und wenn ich den richtig gelesen habe (Farbcodierung), dann soll der 10kOhm (siehe Bild)     haben. Ich hab den mal versucht den zu messen. Mein Multimeter zeigt 8,05 kOhm (Einstellung 20kOhm) an.

Die Formel die ich gefunden habe lautet: Vref = Imax x (5 x Rs)

Das würde dann heißen 2.1 A x 70% = 1,47 A
VRef = 1,47A x 5 x 10 = 73,5 V, das kann ja gar nicht stimmen. Das wär ja die 100 Spannung von oben.


Hab dann noch eine Frage, habe bei den drei Motoren jeweils 1/8 Schritt eingestellt. Würdet ihr mir eher zu 1/16 Schritten raten. Hab im Forum schon gelesen, dass es da Probleme gibt mit den 1/16 Schritten. Als Netzteil möchte ich ein 12 V 5A Computernetzteil anschließen.

Das nächste Problem ist, wo ich die 6 Endschalter (2 je Achse) anschließe? Auf dem Shield sind jeweils ein schwarzer und ein weißer Pin mit der Bezeichnung Z+, Z-, Y+, Y- usw.  Liege ich da richtig, dass der jeweils weiße Pin der Plus und der schwarze Pin GND ist. Wenn ja, dann könnte ich die 2 Endschalter für z.B. die Z-Achse je einen an Z+ und einen an Z- anschließen.

Zu guter Letzt würde ich noch gern wissen, an welche Pins ich die Tastplatte und den Werkzeuglängensensor anschließen muss. 
Möchte die Fräse dann mit Estlcam betreiben.

Danke!

Schöne Grüße
Bernhard
Zitieren
#2
Diese Endstufen sind nicht so wirklich für den Betrieb an einer Fräse ausgelegt, schau dir doch mal dieser Video an.

Gruß Uwe
Stepcraft 600/2, Sorotec Compact-Line 605, EstlCAM, WinPcNc V3, DIY Reprap Prusa i3, Ender 3, 15W Laser (noch in der Erprobung), 4. Achse (Drehachse)

Anfragen, die einem Themenbereich im Forum zugeordnet werden können, bitte auch dort stellen. Entsprechende Fragen per Mail oder PN werden nicht beantwortet.


YouTube
Zitieren
#3
Hallo und Danke Uwe,

ich weiß, dass meine Komponenten die unterste Ebene darstellen, aber ich möchte es erstmal versuchen um Erfahrungen zu sammeln.
Die Treiberbausteine, die Du in Deinem Video verwendest, mit dem kleinen Chip drauf, von denen wird auch abgeraten, da diese extrem unzuverlässig sein sollen. Ich habe deshalb auch die anderen gekauft, die einen größeren Chip (ungefähr doppelt so groß wie deine in dem Video) drauf haben, so zumindest in einem Video auf YouTube erklärt. Ich kann dir aber nicht sagen, ob die dann besser sind als die anderen, dazu muss ich die erstmal zum laufen bringen und dafür hätte ich die Aussage gebraucht, wie hoch die Spannung eingestellt werden soll. Ich werde mal weitersuchen, ob ich noch wo was finde, dass mir bei der Einstellung hilft.

Viele Grüße
Bernhard
Zitieren
#4
Hab noch einen Nachtrag zu meinem ersten Post. Der Widerstand, den ich gemessen habe ist nicht der Richtige weil ich den auf dem Shield gemessen habe. Auf dem Treiber ist auch einer und der hat 0,1 kOhm, dann würde es oben ja passen bei der Berechnung. VRef = 1,47A x 5 x 0,1 = 0,735 V.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste