Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Konturen nicht geschlossen und teilweise gar nicht gelasert
#1
Hallo,

erstmal schöne Feiertage an alle Mitlesenden.

Ich habe heute mal kurz einen Test mit meinem 20 Watt Dioden Laser an meiner CNC gemacht.
Das Ergebnis sieht komisch aus obwohl es in WinPC  einwandfrei angezeigt wird.

   

Die äusseren Konturen fehlen komplett, man sieht nur die Einstechpunkte (mit Kuli umrandet)
das Rechteck und der Kreis sind auch nicht komplett geschlossen, da fehlt auch einiges.

   

Die Datei und den Postprozessor von Estlcam für WinPC hänge ich hier mal mit an,
vieleicht verbirgt sich der Fehler ja da drinne.
Welche Einstellungen unter den Parametern für den Laser ganz korrekt sind ist mir auch noch nicht so ganz klar.

   

Vielleicht hat ja jemand von Euch eine Idee.

Für weiterführende Tipps bin ich immer dankbar.


Angehängte Dateien
.zip   Datei u PP.zip (Größe: 1,37 KB / Downloads: 6)
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#2
Moin,

interessantes Resultat und noch interessanterer G-Code. Der schmeißt ja mit M05 nur so um sich...

Versuchen wir mal zu eruiren, woran das wirklich liegt. Schmeiß mal bitte alle M05 aus dem Code, bis auf das M05 vor M30.
sswjs, aka Jens

High-Z 1000, FME1050, Sorotec HL6045, FME1050-1, Stepcraft 600 V1, FME1050-1, Solidworks, HSMXpress, ESTLCam, NC-Corrector, WINPC-NC 2.5
Zitieren
#3
Hallo,

ich habe den GCode entsprechend  geändert und heute nachmittag mal kurz getestet.
Leider brachte es keinerlei Änderung.

Hier noch der geänderte GCode

%
(Projekt Lasertest ubo 90_30)
(Erstellt mit Estlcam Version 11 Build 11,231)
(Laufzeit ca. 00:00:20 Stunden)

(Benoetigte WerkzeugeSmile
(Laser)


G90

G00 Z0.0000


(Nr. 1: Gravur 16)

G00 X9.7500 Y0.0000
G04 F500
M03

G01 X60.0000 F30.000 S90
M05



(Nr. 2: Gravur 18)

G00 X30.6053 Y18.4495 Z0.0000
G04 F500
M03

G03 X48.6734 Y37.1188 I3.6447 J14.5505 F30.000
G03 X23.4713 Y43.4316 I-14.4234 J-4.1188
G03 X30.6053 Y18.4495 I10.7787 J-10.4316
M05



(Nr. 3: Gravur 17)

G00 X9.2500 Y8.0000 Z0.0000
G04 F500
M03

G01 X59.2500 F30.000
G01 Y58.0000
G01 X9.2500
G01 Y8.0000
M05



(Nr. 4: Gravur 13)

G00 X0.0000 Y56.7500 Z0.0000
G04 F500
M03

G01 Y8.7500 F30.000
M05



(Nr. 5: Gravur 14)

G00 X9.2500 Y66.2500 Z0.0000
G04 F500
M03

G01 X60.0000 Y66.7500 F30.000
M05



(Nr. 6: Gravur 15)

G00 X67.7500 Y57.7500 Z0.0000
G04 F500
M03

G01 X68.2500 Y8.2500 F30.000
M05


M05
M30



Erstellt hatte ich den GCode in Estlcam mit dieser Werkzeugliste die ich vorläufig mal für den Laser angelegt habe.

   
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#4
Moin,

die M05 sind doch immer noch drin. Confused
sswjs, aka Jens

High-Z 1000, FME1050, Sorotec HL6045, FME1050-1, Stepcraft 600 V1, FME1050-1, Solidworks, HSMXpress, ESTLCam, NC-Corrector, WINPC-NC 2.5
Zitieren
#5
Hallo,

ich hatte in Estlcam bei den Programm-Einstellungen nur die M05 weggenommen die hier mit den roten Pfeilen gekennzeichnet sind. Bei Laser, Plasma, Wasserstrahl hatte ich bei Schnitt beenden (roter Strich) das M05 drinne gelassen,
weil ich dachte wenn ein Schnitt gestartet wird muss er auch das Kommando bekommen Schnitt beenden.
Die bisherigen Estlcam-Einstellungen hatte ich von jemandem, von dem ich überzeugt bin, dass er die Materie versteht Wink 

   
   
   
   
   

Da Du erwähntest dass immer noch M05 im GCode enthalten ist,
habe ich eben manuell mal alle M05,  ausser das M05 vor M30 entfernt.

Ich habe dies gleich getestet und das Resultat war leider ohne Änderung.

Hier  zur Kontrolle gerne nochmal der korrigierte GCode:

%
(Projekt Lasertest ubo 90_30)
(Erstellt mit Estlcam Version 11 Build 11,231)
(Laufzeit ca. 00:00:20 Stunden)

(Benoetigte WerkzeugeSmile
(Laser)


G90

G00 Z0.0000


(Nr. 1: Gravur 16)

G00 X9.7500 Y0.0000
G04 F500
M03

G01 X60.0000 F30.000 S90




(Nr. 2: Gravur 18)

G00 X30.6053 Y18.4495 Z0.0000
G04 F500
M03

G03 X48.6734 Y37.1188 I3.6447 J14.5505 F30.000
G03 X23.4713 Y43.4316 I-14.4234 J-4.1188
G03 X30.6053 Y18.4495 I10.7787 J-10.4316




(Nr. 3: Gravur 17)

G00 X9.2500 Y8.0000 Z0.0000
G04 F500
M03

G01 X59.2500 F30.000
G01 Y58.0000
G01 X9.2500
G01 Y8.0000




(Nr. 4: Gravur 13)

G00 X0.0000 Y56.7500 Z0.0000
G04 F500
M03

G01 Y8.7500 F30.000




(Nr. 5: Gravur 14)

G00 X9.2500 Y66.2500 Z0.0000
G04 F500
M03

G01 X60.0000 Y66.7500 F30.000




(Nr. 6: Gravur 15)

G00 X67.7500 Y57.7500 Z0.0000
G04 F500
M03

G01 X68.2500 Y8.2500 F30.000



M05
M30


Ich vermute den Fehler ja eher in einer meiner Einstellungen von WinPC,
da das Entfernen von den M05 in Estlcam leider keinen Erfolg brachte.

Schönen Sonntag noch.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#6
Moin,

na ja, erst mal was im G-Code ausschließen. Fehlersuche ist nun mal nur im Ausschlußverfahren möglich. Und da ich keinen Laser hab...

So, mach mal den Haken raus:

   

und dann lädst du mal den von mir bearbeiteten G-Code:

Code:
%
(Projekt Lasertest ubo 90_30)
(Erstellt mit Estlcam Version 11 Build 11,231)
(Laufzeit ca. 00:00:20 Stunden)

(Benoetigte WerkzeugeSmile
(Laser)

G90
G00 Z0.0000
M03

(Nr. 1: Gravur 16)
G00 X9.7500 Y0.0000
G04 F500
G01 X60.0000 F30.000 S90

(Nr. 2: Gravur 18)
G00 X30.6053 Y18.4495 Z0.0000
G04 F500
G03 X48.6734 Y37.1188 I3.6447 J14.5505 F30.000
G03 X23.4713 Y43.4316 I-14.4234 J-4.1188
G03 X30.6053 Y18.4495 I10.7787 J-10.4316

(Nr. 3: Gravur 17)
G00 X9.2500 Y8.0000 Z0.0000
G04 F500
G01 X59.2500 F30.000
G01 Y58.0000
G01 X9.2500
G01 Y8.0000

(Nr. 4: Gravur 13)
G00 X0.0000 Y56.7500 Z0.0000
G04 F500
G01 Y8.7500 F30.000

(Nr. 5: Gravur 14)
G00 X9.2500 Y66.2500 Z0.0000
G04 F500
G01 X60.0000 Y66.7500 F30.000

(Nr. 6: Gravur 15)
G00 X67.7500 Y57.7500 Z0.0000
G04 F500
G01 X68.2500 Y8.2500 F30.000

M05
M30
Der Laser sollte jetzt am Anfang angemacht werden und alles abfahren. Der sollte auch bis zum Ende an bleiben.
Es wird also auch G00 gelasert, wo er nicht sollte. Smile

Lasert er nicht alles musste deine Hardware überprüfen...
... oder mir noch mehr Einstellungen von WinPC-NC zeigen. Confused

Lasert er alles, dann Haken wieder rein und nochmal. Dann sollte G00 nicht mehr gelasert werden.
sswjs, aka Jens

High-Z 1000, FME1050, Sorotec HL6045, FME1050-1, Stepcraft 600 V1, FME1050-1, Solidworks, HSMXpress, ESTLCam, NC-Corrector, WINPC-NC 2.5
Zitieren
#7
Hallo,

da ich ja neugierig bin, habe ich den Code von Dir gleich gespeichert und ab zur Fräse.
Dann den Haken raus, wie von Dir erwähnt und siehe da,

   

es wurden alle Konturen gelasert. G0 wurde allerdings nicht gelasert.
Warum dies der Fall ist habe ich zwar jetzt nicht verstanden, aber es funktioniert jetzt wenigstens. Smile


Daraufhin habe ich auch den ersten Code mit den vielen M05 geladen und gelasert,
dieser war dann identisch mit Deinem Code, also lag es schon mal nicht an den M05.

Es sind zwar jeweils noch die Einstechpunkte zu sehen, aber jetzt kann ich mich wenigsten
an weiteren Einstellungen versuchen.


Meinst Du diese Einstellungen in WinPC?
- Grundeinstellungen / Zubehör
- Grundeinstellungen / Spindel
- Technologie
- Datenformat


Da kann ich gerne noch Screenshots machen.
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#8
Moin,

na wenn's funzt, brauch ich nix mehr von dir.


Die Einstechlöcher werden übrigen vom G04 im G-Code verursacht.

Also das
Code:
G04 F500
noch raus...
sswjs, aka Jens

High-Z 1000, FME1050, Sorotec HL6045, FME1050-1, Stepcraft 600 V1, FME1050-1, Solidworks, HSMXpress, ESTLCam, NC-Corrector, WINPC-NC 2.5
Zitieren
#9
Servus,

das werde ich morgen dann gleich entfernen und ausprobieren und natürlich auch Bescheid geben.
Vielen Dank schon mal für die Hilfe ?
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren
#10
Servus,

also hier die Rückmeldung die ich angekündigt hatte.
Die Einstechpunkte sind jetzt schon weniger sichtbar, aber immer noch etwas vorhanden,
ich habe zwar keine Ahnung ob und wie man die komplett weg bekommt,
aber Dank Deiner Hilfe bin ich schon mal etwas weitergekommen. Vielen Dank.

   

Ich werde mich dann demnächst mal an das bessere Fokussieren des Laser machen.
Des Weiteren werde ich auch mal den Geschwindigkeitstest und den Graustufentest versuchen.


Schöne Grüße
Smile   gekaufte Eigenbau-Fräse: Kress 1050 FME-1 DI, StepMAX 3/30-Steuerung,
WinPC-NC v3.40/72, EstlCAM v11.235, SketchUp 2016 Pro, CorelDRAW X6,
Fusion360 in Lernphase
3D Druck: Artillery Genius und Cura 4.4.1

Schöne Grüße
Norbert

NoPlease
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste